compat not needed with cdbs