Looks like we need Cabal >= 1.14