Support new "userlevel" options.