Released vte-0.13.3. vte_0_13_3
authorBehdad Esfahbod <behdad@gnome.org>
Tue, 11 Jul 2006 01:00:25 +0000 (01:00 +0000)
committerBehdad Esfahbod <behdad@src.gnome.org>
Tue, 11 Jul 2006 01:00:25 +0000 (01:00 +0000)
2006-07-10  Behdad Esfahbod  <behdad@gnome.org>

        Released vte-0.13.3.

        * NEWS: Updated.

        * configure.in: Bumped version to 0.13.3.

        * src/Makefile.am: Bumped libtool version to 10:0:1.

ChangeLog
NEWS
configure.in
src/Makefile.am

index 136de41..6644c4e 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,13 @@
+2006-07-10  Behdad Esfahbod  <behdad@gnome.org>
+
+       Released vte-0.13.3.
+
+       * NEWS: Updated.
+
+       * configure.in: Bumped version to 0.13.3.
+
+       * src/Makefile.am: Bumped libtool version to 10:0:1.
+
 2006-07-10  Behdad Esfahbod  <behdad@gnome.org>
 
        Bug 141985 – vte does not respond to 'CSI 2 1 t' or 'CSI 2 0 t' with
diff --git a/NEWS b/NEWS
index bbc6aff..6ce8dfb 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,19 @@
+0.13.3
+       Bug 121904 – copy-paste of empty line
+       Bug 25290 – Small UI tweak to select-by-word (only select only letter
+                   at a time for non-word characters)
+       Bug 339986 – Patch to select localized strings exactly
+                    Patch from Takao Fujiwara
+       Bug 311855 – Race in vte leads to blocking of input.
+                    Patch from Kalle Raiskila
+       Bug 342396 – Ctrl-space sends " ", not NUL.
+       Bug 345377 – real transparency
+                    Patch from Kristian Høgsberg <krh redhat.com>
+       Bug 345514 – -no-undefined doesn't work with latest libtool
+       Bug 141985 – vte does not respond to 'CSI 2 1 t' or 'CSI 2 0 t' with
+                    the correct window/icon title
+                    Patch from Mariano Suárez-Alvarez
+
 0.13.2
        Bug 344666 – Problems with *_CFLAGS and *_LDFLAGS in makefiles
                     Patch from Stepan Kasal <kasal@ucw.cz>.
index c3fe29c..629d6a9 100644 (file)
@@ -1,5 +1,5 @@
 AC_PREREQ(2.56)
-AC_INIT(vte, [0.13.2],
+AC_INIT(vte, [0.13.3],
         [http://bugzilla.gnome.org/enter_bug.cgi?product=vte])
 AC_CONFIG_SRCDIR([src/vte.c])
 AM_INIT_AUTOMAKE(1.6)
index 1d348d3..23fc223 100644 (file)
@@ -97,13 +97,13 @@ libvte_la_SOURCES = \
 # Libtool shared library versioning stuffs.
 # REVISION gets incremented whenever the source code changes without adding
 # an API or ABI change.
-VERSION_REVISION=2
+VERSION_REVISION=0
 # CURRENT must be incremented when an API or ABI change (addition or removal)
 # is made, and REVISION must be reset to 0 when this happens.
-VERSION_CURRENT=9
+VERSION_CURRENT=10
 # AGE must be incremented when an API or ABI addition is made, and REVISION
 # must be reset to 0 when this happens.
-VERSION_AGE=0
+VERSION_AGE=1
 libvte_la_LDFLAGS = $(LDFLAGS) \
        -version-info $(VERSION_CURRENT):$(VERSION_REVISION):$(VERSION_AGE) \
        -export-symbols-regex "^vte_terminal_.*|^_vte_pty_.*|^vte_reaper_.*|_vte_debug_.*"