Require glib >= 2.18.0 as earlier glib versions had a totally bogus