Move libtool versioning to configure so you just have to update one file